Analisi dati RPS3

Sistemi elettronici di controllo e monitoraggio, Arduino, Rasberry ecc.

Moderatori: gasala50, FabioR

mbrusa
Messaggi: 88
Iscritto il: sab lug 04, 2009 1:42 pm
Località: Prov. Lecco

Analisi dati RPS3

Messaggioda mbrusa » gio mar 29, 2012 5:09 pm

Buonasera a tutti
A inizio marzo, ho provato a registrare i dati della centralina RPS3, bello, ma niente di imprevisto o di anomalo.
Dopo una settimana ho smesso, anche perchè devo tenere acceso il PC tutto il giorno.
Ho avuto la conferma che la produzione reale ricalcolata con la correzione di Sergio era tra il 22 e 29% in più, in linea con quella presunta.
Allego come esempio il grafico del 01/03

Da qualche giorno il riscaldamento non parte più, oggi ho provato la registrazione nelle nuove condizioni.
Sorpresa, la produzione ricalcolata è quasi il doppio di quella della RPS3, 4,8/9,1 kWh, se poi faccio il calcolo considerando la variazione di temperatura dei 500 litri fino alle 13.30, la differenza è ancora maggiore. Boh
Allego grafico di oggi

Altra sorpresa
Con l'ultima partenza alle 17, ho 2 minuti di potenza negativa (TV sempre inferiore a TR), quindi inutile.
Come evitare queste ripartenze? Alzando DeltaT ON (ora a 15K) o abbassando TK cons (ora a 95K)?
TK max è 80K.
Un'altra cosa, l'andamento di TV nel pomeriggio non è un pò strano?
Allegati
29 marzo 2012.JPG
(84.73 KiB) Mai scaricato
01 marzo 2012.JPG
(69.47 KiB) Mai scaricato

Avatar utente
sergio&teresa
Messaggi: 1744
Iscritto il: mer giu 24, 2009 10:29 pm

Re: Analisi dati RPS3

Messaggioda sergio&teresa » gio mar 29, 2012 7:20 pm

L'andamento della TV e' strano si'... non e' che ti entra qualche segnale nella RPS/3 dall'interfaccia che usi? Te lo chiedo perché a noi (a me e gasala) era capitato che l'interfaccia facesse impazzire il dato del flow sensor. Poi gasala ha fatto qualche truschino... ;) e la cosa si e' magicamente sistemata.

Non c'è da stupirsi che l'errore sia del 100% a T molto alte. La staratura delle sonde cresce al crescere della T, quando la RPS/3 ti da' una TR di 70 gradi in realtà sono 66... Con una TV di 74 gradi l'errore istantaneo diventa del 100%... sommali tutti...

Sulla verifica del ricalcolo cosa hai considerato? Solo TS, la media TR-TS? In generale la verifica io la farei solo per un periodo in cui la stratificazione si e' praticamente azzerata e l'accumulo cresce uniformemente, così ne puoi usare anche una sola.

Sulle potenze negative credo si possa far poco. Se puoi abbassa il Tempo P2...
Segui il mio impianto su Portalsole:
Liveplant3

mbrusa
Messaggi: 88
Iscritto il: sab lug 04, 2009 1:42 pm
Località: Prov. Lecco

Re: Analisi dati RPS3

Messaggioda mbrusa » gio mar 29, 2012 9:09 pm

Grazie Sergio
dici che per le potenze negative non c'è soluzione?
Il tempo P2 è a 90 sec, purtroppo a 80 quando fa freddo a volte va in blocco.

Come verifica, ho considerato che il deltaT minimo è 16°C (variazione TS), quindi produzione minima 0,5*16*1,163=9,3kWh, il deltaT medio è difficile da calcolare o da stimare, ma è certamente più alto.

Avatar utente
sergio&teresa
Messaggi: 1744
Iscritto il: mer giu 24, 2009 10:29 pm

Re: Analisi dati RPS3

Messaggioda sergio&teresa » gio mar 29, 2012 9:40 pm

Il problema è che se anche alzi il DTon, se non c'è sufficiente irraggiamento per mantenere potenza anche ad alte T operative appena passato il transiente (che durerà un po' di più, ma poco) di trippa per gatti non ce n'è... e quindi la TV va giù.

A meno che tu non intenda usare il DTon per evitare la riaccensione dell'impianto quando la TR è sopra 70° (e quindi alzando il DTon a 25° la circolazione non ti riparte quando la TK tocca i 95°).

Però così ti castri al mattino e in caso di tempo variabile. Potresti invece abbassare la TKcons a 85° così fino a che TR non scende sotto 69° l'impianto non ti riparte. Dal grafico di oggi vedo che 85° di TK ti bastano e avanzano per portare la TS a 81°.

Un'altra stranezza del tuo grafico di oggi è che intorno a 80° la TV ti va sopra la TK, cosa impossibile... ma potrebbe essere semplicemente una innocua straratura della TK.

Per quanto riguarda il ricalcolo, se riguardi bene la discussione in cui ho presentato la correzione avevo scritto che c'è una piccola sottostima residua, il cui motivo è ancora ignoto...

Ciao
Sergio
Segui il mio impianto su Portalsole:
Liveplant3

FabioR
Messaggi: 125
Iscritto il: ven set 30, 2011 8:11 am

Re: Analisi dati RPS3

Messaggioda FabioR » ven mar 30, 2012 8:12 am

io per sicurezza ho collegato solo il pin rx alla RPS3, lasciando tx scollegato proprio per evitare di inviare qualche comando non voluto alla centralina

mbrusa
Messaggi: 88
Iscritto il: sab lug 04, 2009 1:42 pm
Località: Prov. Lecco

Re: Analisi dati RPS3

Messaggioda mbrusa » ven mar 30, 2012 10:48 am

Per le ripartenze inutili, penso anch'io si possa risolvere abbassando TKcons, proverò gradualmente.

Sull'andamento della TV, non credo sia un problema di disturbi elettrici, ci sarebbere sempre. Anch'io ho collegato solo rx.
Io ho pensato a un residuo di acqua che rimane nei pannelli, evaporando, l'unico sfogo è attraverso il FlowSensor che sente la T del vapore.

TV sopra TK non è del tutto impossibile, i pannelli potrebbero in alcune zone avere T superiori alla TK
Allego il dettaglio dei dati in quel momento particolare.

Ciao
Allegati
TVsopraTK.xls
(20 KiB) Scaricato 219 volte

mbrusa
Messaggi: 88
Iscritto il: sab lug 04, 2009 1:42 pm
Località: Prov. Lecco

Re: Analisi dati RPS3

Messaggioda mbrusa » ven mar 30, 2012 7:54 pm

mbrusa ha scritto:Io ho pensato a un residuo di acqua che rimane nei pannelli, evaporando, l'unico sfogo è attraverso il FlowSensor che sente la T del vapore.

Mi rispondo da solo.
E' una teoria che non regge, la TV aumenta anche nel tardo pomeriggio quando la TK è più bassa di TV!
Forse è il livello nel sanicube troppo alto, i due raccordi in ottone del FlowSensor scottano anche la sera a impianto fermo da ore, non ci si può mettere le mani!

Oggi con TKcons a 90K, le ripartenze con potenza negativa non ci sono state.

Avatar utente
sergio&teresa
Messaggi: 1744
Iscritto il: mer giu 24, 2009 10:29 pm

Re: Analisi dati RPS3

Messaggioda sergio&teresa » ven mar 30, 2012 9:30 pm

Così, solo per toglierti il dubbio, prova a staccare il jack della seriale.
Segui il mio impianto su Portalsole:
Liveplant3

mbrusa
Messaggi: 88
Iscritto il: sab lug 04, 2009 1:42 pm
Località: Prov. Lecco

Re: Analisi dati RPS3

Messaggioda mbrusa » mer apr 04, 2012 10:07 am

sergio&teresa ha scritto:Così, solo per toglierti il dubbio, prova a staccare il jack della seriale.

Non è un problema di disturbi, quando la TS rimane sotto i 70°C l'andamento della TV è regolare.
Mi sono accorto di una cosa, con TS vicina agli 80°C, anche a impianto fermo, si sente un gorgoglio continuo provenire dal sanicube. Togliendo il tappo di carico, il rumore si sente in modo più evidente. Il livello non è al massimo e la temperatura superficiale è vicina la valore della TS.
fino a quando si sente questo rumore, la TS varia in modo strano.
Cercherò di approfondire quando torna il sole.

Per le ripartenze con potenza negativa, capita ancora ma meno di prima, purtroppo il minimo impostabile di TKcons è 90K.

Ciao


Torna a “Domotica, monitoraggio e controllo.”



Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti